Readyboost service wont start (no Readyboost tab) - Components

Hi. I have been trying for a couple of weeks to use readyboost and have found that the service won't start. it seems that this means that the USB drive that I'm am using isn't even being tested by readyboost. There is no readyboost tab when I look at the properties of the drive and when I go to readyboost in services.msc it does not show as started (the status column is blank). An older USB drive that my son lost used to work with readyboost but stopped working. I'm now trying with a Kingmax 4GB U-drive which I've found on lists on the net as being compatible.

The core issue seems to be that the readyboost service wont start. When I try and start it from services.msc I get an error message that says "Windows could not start the readyboost service on local computer. Error 6: The handle is invalid". I've searched this problem heaps on google and have only found one person that seems to have had the same problem. They fixed it by loading a bit of someone else's registry but the link to the registry file is dead. I also found someone that had problems starting another service who got an invalid handle error, who fixed it by changing the account that the service logged on with. When I try this it still wont start - I get "Windows could not start the readyboost service on local computer. Error 1079: The account specified for this service is different for the account specified for other services running in the same process".

I've looked at the dependencies of the readyboost service. None of the seem to appear in my services list. I don't know if that could be the problem or if it is, what to do about it. The 4 listed are:

- File Information FS MiniFilter
- Readyboost Caching driver
- Remote Procedure call
- Software Licensing

I think that the last one (Software Licensing) could relate to the fact that I have Adobe Premiere Elements installed.

My PC runs fine without Readyboost (I have a dual core E8400 with 4GB of 1GB Crucial matched DDR2 sticks and a 950 GB SATA 0 array), so this isn't urgent from a PC working point of view but it is one of those things that is really frustrating because it should work.

If anyone can help put me out of my misery it would be most appreciated.




Domen keys Domen urls

The keys on which they find this page